L’errore 1045 di MySQL si verifica in genere quando si tenta di accedere al proprio database MySQL tramite WordPress. La richiesta verrà rifiutata se il server ritiene che l’utente non sia autorizzato a eseguire l’azione. Ad esempio, è possibile che si stia utilizzando una password errata o che non si disponga delle autorizzazioni necessarie.
Fortunatamente, esistono diversi modi per risolvere l’errore MySQL 1045. Ad esempio, puoi reimpostare la password, controllare i permessi dell’utente e verificare la porta.
Questo articolo illustra alcune cause comuni dell’errore MySQL 1045 e ti guida attraverso quattro metodi per risolverlo. Cominciamo!
Che cos’è l’errore 1045 di MySQL?
Questo errore si presenta in diverse forme, ma in questo articolo lo chiameremo semplicemente “errore 1045 di MySQL”. Tuttavia, l’errore potrebbe anche apparire come “Error 1045 (28000) access denied for user ‘username’@’hostname’”:

Potresti riscontrare l’errore 1045 di MySQL quando provi ad accedere al database MySQL tramite WordPress. MySQL è un sistema di database SQL (Structured Query Language) comunemente utilizzato per aggiungere, accedere e gestire i contenuti su un sito web WordPress.
Altri sistemi di database diffusi che utilizzano SQL sono PostgreSQL e SQL Server, oltre a SQLite e MariaDB.
MariaDB è il sistema che si trova alla base dei siti WordPress su Kinsta ed è un sostituto diretto di MySQL. Tutto ciò che riguarda l’“Errore 1045” e MySQL vale anche per MariaDB.
Quando si verifica questo messaggio di errore, significa che non si è autorizzati ad accedere al database. Ad esempio, è possibile che si stia utilizzando una password errata, un nome utente errato o che si disponga di autorizzazioni insufficienti.
Quali sono le cause dell’errore 1045 di MySQL?
Ecco alcune delle cause principali dell’errore 1045 di MySQL:
- Permessi insufficienti — Non ti verrà concesso l’accesso al database MySQL se non disponi dei necessari permessi di WordPress.
- Utente inesistente — L’errore compare anche se non sei registrato come utente sul server. In questo caso, il database semplicemente non è a conoscenza della tua esistenza.
- Credenziali di accesso errate — La causa dell’errore potrebbe essere semplicemente l’utilizzo di password e nome utente sbagliati. Ciò accade spesso se si dispone di più host, poiché è facile confondere le password.
- Host errato — Se non si specifica l’host a cui connettersi, MySQL tenterà di connettersi a localhost. Nel frattempo, si potrebbe cercare di connettersi a un host o a una porta diversi.
- Interferenza di Bash — I caratteri speciali presenti nella password possono essere interpretati da Bash. Tuttavia, è possibile racchiudere la password tra virgolette singole per evitare questo problema.
- Nessun SSL — Per accedere al database, Secure Sockets Layer (SSL) potrebbe essere richiesto, ma è possibile che non si disponga di un certificato SSL valido.
Una volta identificata la causa dell’errore 1045 di MySQL, sarai in una posizione migliore per applicare la soluzione corretta. A quel punto, potrai eliminare il messaggio di errore e tornare al lavoro.
Come risolvere l’errore 1045 di MySQL (4 metodi)
Ora che conosci un po’ meglio l’errore 1045 di MySQL, diamo un’occhiata a quattro semplici metodi per risolverlo.
1. Verificare che l’utente disponga dei privilegi necessari
Le credenziali utente e i privilegi di accesso sono gestiti nel mysql database di sistema — in particolare, nelle tabelle user e db di quel database. Una delle cause principali dell’errore 1045 di MySQL è che il nome utente nella configurazione di WordPress non dispone dei permessi necessari per accedere al database del CMS in MySQL.
Se si dispone di accesso a MySQL dalla riga di comando del proprio server (sia sul computer stesso che tramite SSH), è possibile applicare i permessi richiesti effettuando l’accesso a MySQL come utente root:
mysql -u root -p
Dopo aver inserito la password di questo superutente ed effettuato l’accesso, è possibile concedere tutti i permessi che potrebbero essere utilizzati per un database di WordPress eseguendo il comando GRANT. Utilizzando come esempi il nome utente “wp-admin” e un database di WordPress su “localhost” denominato “companydb”, il comando sarebbe:
GRANT SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, INDEX, ALTER, CREATE TEMPORARY TABLES, LOCK TABLES ON companydb.* TO 'wp-admin'@'localhost';
Presso molti provider di hosting web è anche possibile verificare i privilegi utente tramite phpMyAdmin.
Su Kinsta non si dispone dell’accesso “root” a MariaDB in phpMyAdmin, ma le credenziali di accesso al database necessarie per la configurazione di WordPress sono sempre disponibili nella dashboard di MyKinsta.
2. Assicurarsi di utilizzare il nome utente e la password corretti
Sebbene possa sembrare semplice, a volte la causa dell’errore 1045 di MySQL è l’utilizzo di credenziali di accesso errate. Fortunatamente, puoi verificare queste informazioni consultando il tuo file wp-config.php.
Puoi trovare questo file accedendo al pannello di controllo del tuo host e utilizzando un file manager. In alternativa, puoi connetterti al tuo sito tramite SFTP.
Con questo metodo, devi innanzitutto individuare la directory principale del sito, che solitamente è denominata public_html. Al suo interno, dovresti trovare il file wp-config.php:

Apri il file e verifica che DB_USER e DB_PASSWORD abbiano i valori corretti (di solito impostati al momento dell’installazione di WordPress).
Se non ricordi la password che hai creato e il tuo host utilizza cPanel, vai su Database e poi clicca su MySQL.
Se sei cliente Kinsta, puoi trovare le credenziali del database in MyKinsta accedendo a Siti > nome-sito per raggiungere la pagina Informazioni sul sito e quindi scorrendo verso il basso fino alla sezione Accesso al database:

Puoi copiare il nome utente e la password da quei campi in MyKinsta.
3. Reimpostare la password
Se non ricordi la password del database, puoi reimpostarla per accedere a MySQL ed eliminare l’errore.
Se disponi dell’accesso da riga di comando a MySQL, puoi effettuare l’accesso come utente root e aggiornare la password per gli utenti del database di WordPress in questo modo:
ALTER USER 'wp-admin'@'localhost' IDENTIFIED BY 'NewStrongPassword';
Il comando sopra riportato imposterà una nuova password per un utente denominato wp-admin.
4. Assicurarsi che il server MySQL sia in ascolto sulla porta corretta
Un’altra soluzione rapida all’errore 1045 di MySQL consiste nell’assicurarsi che il server sia in ascolto sulla porta corretta. Innanzitutto, però, è utile verificare che MySQL sia in esecuzione.
Puoi controllare lo stato del server eseguendo il seguente comando:
systemctl status mysql
Se il server non è in esecuzione, avvialo utilizzando questo comando:
systemctl start mysql
Ora, la porta predefinita per MySQL è la 3306, quindi è possibile verificare che stia utilizzando la porta corretta. Aprire un terminale o un prompt dei comandi sul server in cui è installato MySQL.
Quindi, connettiti al server utilizzando questo comando:
mysql -username -password
Ora, digita il seguente comando per visualizzare il numero di porta su cui il server MySQL è in ascolto:
SHOW VARIABLES LIKE ‘port’:
È possibile modificare il parametro della porta qui oppure nel file di configurazione. Successivamente, riavviare il server MySQL per applicare le modifiche.
Riepilogo
Gli errori di WordPress possono essere frustranti e impedire di apportare modifiche importanti al proprio sito. L’errore 1045 di MySQL è particolarmente problematico perché impedisce di accedere al database. Fortunatamente, esistono diversi modi per risolverlo.
Per cominciare, potrebbe essere necessario verificare di disporre dei privilegi necessari per accedere al database. Oppure, potrebbe trattarsi semplicemente di un caso in cui si stanno utilizzando nome utente e password errati. In alternativa, è possibile reimpostare la password o verificare che il server MySQL sia in ascolto sulla porta corretta.
Su Kinsta, tutti i nostri piani offrono un’assistenza di altissima qualità per aiutarti a risolvere rapidamente i problemi. Inoltre, il nostro hosting di database dispone di 24 data center e 300 sedi della rete di distribuzione dei contenuti (CDN): è quindi veloce, sicuro e scalabile. Scopri oggi stesso i nostri piani!